CVE-2021-42638
PrinterLogic Web Stack versions 19.1.1.13 SP9 and below do not sanitize user input resulting in pre-auth remote code execution.
CVSS
8.1
High
EPSS
5.5%
p93
KEV
—
Exploit Today
28
0-100
Published: Feb 1, 2022 · Last modified: Jul 9, 2026 · CWE-77
5.5%EPSS · 30 days5.5%
2026-10-062026-11-02
PrinterLogic Web Stack versions 19.1.1.13 SP9 and below do not sanitize user input resulting in pre-auth remote code execution.
- portswigger.nethttps://portswigger.net/daily-swig/printerlogic-vendor-addresses-triple-rce-threat-against-all-connected-endpoints
- securityaffairs.cohttps://securityaffairs.co/wordpress/127194/security/printerlogic-printer-management-suite-flaws.html
- thecyberthrone.inhttps://thecyberthrone.in/2022/01/26/printerlogic-%F0%9F%96%A8-fixes-critical-vulnerabilities-in-its-suite/?utm_source=rss&utm_medium=rss&utm_campaign=printerlogic-%25f0%259f%2596%25a8-fixes-critical-vulnerabilities-in-its-suite
- www.printerlogic.comhttps://www.printerlogic.com/security-bulletin/
- www.securityweek.comhttps://www.securityweek.com/printerlogic-patches-code-execution-flaws-printer-management-suite
- www.yahooinc.comhttps://www.yahooinc.com/paranoids/paranoids-vulnerability-research-printerlogic-issues-security-alert/
- portswigger.nethttps://portswigger.net/daily-swig/printerlogic-vendor-addresses-triple-rce-threat-against-all-connected-endpoints
- securityaffairs.cohttps://securityaffairs.co/wordpress/127194/security/printerlogic-printer-management-suite-flaws.html
- thecyberthrone.inhttps://thecyberthrone.in/2022/01/26/printerlogic-%F0%9F%96%A8-fixes-critical-vulnerabilities-in-its-suite/?utm_source=rss&utm_medium=rss&utm_campaign=printerlogic-%25f0%259f%2596%25a8-fixes-critical-vulnerabilities-in-its-suite
- www.printerlogic.comhttps://www.printerlogic.com/security-bulletin/
- www.securityweek.comhttps://www.securityweek.com/printerlogic-patches-code-execution-flaws-printer-management-suite
- www.yahooinc.comhttps://www.yahooinc.com/paranoids/paranoids-vulnerability-research-printerlogic-issues-security-alert/
CVECVSSEPSSKEVRExploitTitleMod.
CVE-2026-1216087.3 HIG—
———A vulnerability was determined in Qihoo 360 D603-2, D600-2 and D606-6 up to 6.3.2. This vulnerability affects the function on_push_message of the file /fs2/bin/iscm of the component Timezone Push Handler. Executing a manipulation of the argument tz can lead to os command injection. The attack may be launched remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.4.0 is able to resolve this issue. Upgrading the affected component is advised. Firmware 6.4.0 gates the path with a new check_timezone_parameter validation (verified by VulDB vulnerability analysis team via disassembly).9hCVE-2026-12160710.0 CRI—
———A vulnerability was found in Qihoo 360 D603-2, D600-2, D606-6 and D706 up to 6.4.9. This affects the function testspeed_command of the file /fs2/bin/iscm. Performing a manipulation of the argument host results in os command injection. The attack may be initiated remotely. The exploit has been made public and could be used. The vendor was contacted early about this disclosure but did not respond in any way.9hCVE-2026-957277.2 HIG—
———A command injection vulnerability exists in HPE Networking VIA. Successful exploitation could allow an authenticated administrative user to execute arbitrary commands with elevated privileges on the underlying operating system.14hCVE-2026-1059827.2 HIG—
——0Improper input validation in the IPsec VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.16hCVE-2026-1059807.2 HIG—
——0Improper input validation in the WireGuard VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.19hCVE-2026-1059797.2 HIG—
——0Improper input validation in the ZeroTier VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.19h