CVE-2022-42898
PAC parsing in MIT Kerberos 5 (aka krb5) before 1.19.4 and 1.20.x before 1.20.1 has integer overflows that may lead to remote code execution
CVSS
8.8
High
EPSS
6.9%
p94
KEV
—
Exploit Today
28
0-100
Published: Dec 25, 2022 · Last modified: Oct 14, 2026 · CWE-190
6.2%EPSS · 30 days6.9%
2026-10-032026-10-31
PAC parsing in MIT Kerberos 5 (aka krb5) before 1.19.4 and 1.20.x before 1.20.1 has integer overflows that may lead to remote code execution (in KDC, kadmind, or a GSS or Kerberos application server) on 32-bit platforms (which have a resultant heap-based buffer overflow), and cause a denial of service on other platforms. This occurs in krb5_pac_parse in lib/krb5/krb/pac.c. Heimdal before 7.7.1 has "a similar bug."
- bugzilla.samba.orghttps://bugzilla.samba.org/show_bug.cgi?id=15203
- github.comhttps://github.com/heimdal/heimdal/security/advisories/GHSA-64mq-fvfj-5x3c
- github.comhttps://github.com/krb5/krb5/commit/ea92d2f0fcceb54a70910fa32e9a0d7a5afc3583
- security.gentoo.orghttps://security.gentoo.org/glsa/202309-06
- security.gentoo.orghttps://security.gentoo.org/glsa/202310-06
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20230216-0008/
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20230223-0001/
- web.mit.eduhttps://web.mit.edu/kerberos/advisories/
- web.mit.eduhttps://web.mit.edu/kerberos/krb5-1.19/
- web.mit.eduhttps://web.mit.edu/kerberos/krb5-1.20/README-1.20.1.txt
- www.samba.orghttps://www.samba.org/samba/security/CVE-2022-42898.html
- bugzilla.samba.orghttps://bugzilla.samba.org/show_bug.cgi?id=15203
- github.comhttps://github.com/heimdal/heimdal/security/advisories/GHSA-64mq-fvfj-5x3c
- github.comhttps://github.com/krb5/krb5/commit/ea92d2f0fcceb54a70910fa32e9a0d7a5afc3583
- security.gentoo.orghttps://security.gentoo.org/glsa/202309-06
- security.gentoo.orghttps://security.gentoo.org/glsa/202310-06
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20230216-0008/
- security.netapp.comhttps://security.netapp.com/advisory/ntap-20230223-0001/
- web.mit.eduhttps://web.mit.edu/kerberos/advisories/
- web.mit.eduhttps://web.mit.edu/kerberos/krb5-1.19/
CVECVSSEPSSKEVRExploitTitleMod.
CVE-2026-1193405.5 MED1.9%
——1Tesseract is an open source OCR engine. Prior to 5.5.4, GENERIC_2D_ARRAY::DeSerializeSize in src/ccstruct/matrix.h reads matrix dimensions as signed int32_t values and compares them only with UINT16_MAX, allowing negative values to reach ResizeNoInit. Negative dimensions or a 65535 by 65535 product can create inconsistent allocation state and later out-of-bounds accesses while loading a crafted traineddata file, causing denial of service. This issue is fixed in version 5.5.4.2dCVE-2026-616943.7 LOW20.0%
——6go-xrpl is a Go implementation of the XRP Ledger protocol. In versions through the June 18, 2026 revision identified by the advisory, `ParseMPTAmountBinary` in `internal/ledger/state/ripple_state.go` converts the eight-byte MPT magnitude using `num.Int64()` without checking that it fits in 63 bits. A positive magnitude of at least 2^63 silently wraps into a negative amount without an error. `ParseEscrow` passes 33-byte `sfAmount` fields to the parser and stores `MPTRaw()` in `EscrowData.MPTAmount`, causing incorrect downstream calculations and divergence from rippled's interpretation of the same escrow entry. Independently, `readMPTAmount` in `internal/tx/ledgerfields/decode_stream.go` accepts over-limit magnitudes and surfaces large decimal strings without enforcing the maximum signed 64-bit value. The public codec in codec/binarycodec/types/amount.go already rejects these values, leaving the internal decoders inconsistent with that safe path. A source fix is available in commit 9dbd3935ed6c54f0232f2291edf9c012a0900dd5.2dCVE-2026-1197296.5 MED34.2%
——10A flaw was found in GStreamer. An integer overflow vulnerability in the AV1 LEB128 variable-length integer parser allows a remote attacker to cause a crash in applications that process AV1 media content. By crafting a malformed AV1 bitstream containing an invalid LEB128-encoded value, an attacker can cause integer overflow in the parser, resulting in incorrect length values being used during stream processing, which can lead to a denial of service.2dCVE-2026-1197197.8 HIG5.1%
——2Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability in the blend file thumbnail extractor caused by 32-bit integer overflow in thumb_data_vertical_flip(). Attackers can craft a .blend file with malicious TEST block dimensions that trigger an out-of-bounds write when blender-thumbnailer or the Windows shell extension previews it, causing crashes or code execution.2dCVE-2026-1197187.8 HIG9.3%
——3Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability caused by integer overflow in ptcache_data_alloc() when reading point cache files. Attackers can supply a crafted point cache file with a large totpoint value alongside a .blend file to crash Blender or execute code as the user.2dCVE-2026-1040647.8 HIG11.5%
——3Scribus before 1.6.7 contains an integer overflow vulnerability in the scimgdataloader_tiff TIFF loader that allows attackers to trigger a heap overflow via crafted tile dimensions. Attackers can supply a tiled TIFF with large tile width, height and sample values for a user to import, corrupting heap memory to crash Scribus or execute code.2d