Vulnerabilities exploitable today
406,313in current view
Single score combining CVSS, KEV membership and EPSS. Every CVE with its own record — timeline from publication to active exploitation.
In KEV catalog1,766
New KEV · 24H0
Exploit Today ≥ 701,698
Distribution · last window
- Critical5,563
- High21,577
- Medium20,086
- Low2,090
Filters
Window
Severity
Flags
CVECVSSEPSSKEVRExploitTitleMod.
CVE-2021-229459.1 CRI93.9%
——28When sending data to an MQTT server, libcurl <= 7.73.0 and 7.78.0 could in some circumstances erroneously keep a pointer to an already freed memory area and both use that again in a subsequent call to send data and also free it *again*.18dCVE-2009-1711—93.9%
——28——CVE-2002-1147—93.9%
——28——CVE-2018-8941—93.9%
——28——CVE-2009-4535—93.9%
——28——CVE-2000-0825—93.9%
——28——CVE-2010-2006—93.9%
——28——CVE-2007-3954—93.9%
——28——CVE-2006-6445—93.9%
——28——CVE-2006-0700—93.9%
——28——CVE-2017-8531—93.9%
——28——CVE-2021-35578—93.9%
——28——CVE-2016-6432—93.9%
——28——CVE-2019-0982—93.9%
——28——CVE-2024-4504—93.9%
——28——CVE-2018-71677.5 HIG93.9%
——28Calling Buffer.fill() or Buffer.alloc() with some parameters can lead to a hang which could result in a Denial of Service. In order to address this vulnerability, the implementations of Buffer.alloc() and Buffer.fill() were updated so that they zero fill instead of hanging in these cases. All versions of Node.js 6.x (LTS "Boron"), 8.x (LTS "Carbon"), and 9.x are vulnerable. All versions of Node.js 10.x (Current) are NOT vulnerable.24dCVE-2016-7247—93.9%
——28——CVE-2004-1907—93.9%
——28——CVE-2008-6843—93.9%
——28——CVE-2007-5636—93.9%
——28——CVE-2016-10081—93.9%
——28——CVE-2007-1916—93.9%
——28——CVE-2016-15042—93.9%
——28——CVE-2013-0429—93.9%
——28——CVE-2002-2295—93.9%
——28——CVE-2016-0937—93.9%
——28——CVE-2010-1405—93.9%
——28——CVE-2001-0534—93.9%
——28——CVE-2010-1400—93.9%
——28——CVE-2002-2190—93.9%
——28——CVE-2021-1636—93.9%
——28——CVE-2016-1997—93.9%
——28——CVE-2020-25705—93.9%
——28——CVE-2021-377147.5 HIG93.9%
——28jsoup is a Java library for working with HTML. Those using jsoup versions prior to 1.14.2 to parse untrusted HTML or XML may be vulnerable to DOS attacks. If the parser is run on user supplied input, an attacker may supply content that causes the parser to get stuck (loop indefinitely until cancelled), to complete more slowly than usual, or to throw an unexpected exception. This effect may support a denial of service attack. The issue is patched in version 1.14.2. There are a few available workarounds. Users may rate limit input parsing, limit the size of inputs based on system resources, and/or implement thread watchdogs to cap and timeout parse runtimes.24dCVE-2015-4473—93.9%
——28——CVE-2018-20235—93.9%
——28——CVE-2003-1227—93.9%
——28——CVE-2015-8432—93.9%
——28——CVE-2019-7231—93.9%
——28——CVE-2011-0558—93.9%
——28——