CVE-2026-123023
A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_
CVSS
7.3
Alto
EPSS
—
KEV
—
Exploit Today
—
0-100
Publicado: 5 nov 2026 · Última mod.: 5 nov 2026 · CWE-285 · CWE-863
Sin historial EPSS suficiente todavía.
A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.
- github.comhttps://github.com/agentscope-ai/agentscope/
- github.comhttps://github.com/agentscope-ai/agentscope/commit/6b43b13a46401e86abd3defeed9a8bfe5b37bc6d
- github.comhttps://github.com/agentscope-ai/agentscope/issues/3313
- github.comhttps://github.com/agentscope-ai/agentscope/pull/2629
- github.comhttps://github.com/agentscope-ai/agentscope/releases/tag/v2.0.9
- github.comhttps://github.com/ybyu-ieu/agent-security-advisories/blob/main/agentscope/agentscope-bash-tool-tee-misclassification-arbitrary-file-write.md
- vuldb.comhttps://vuldb.com/cve/CVE-2026-123023
- vuldb.comhttps://vuldb.com/submit/1033131
- vuldb.comhttps://vuldb.com/vuln/431396
- vuldb.comhttps://vuldb.com/vuln/431396/cti