CVE-2026-112285
Thelia before 3.1.5 and 3.2.x before 3.2.4 contains a business logic vulnerability that allows authenticated customers to bypass coupon usag
CVSS
4.3
Média
EPSS
0.3%
p22
KEV
—
Exploit Today
6
0-100
Publicado: 19 de out. de 2026 · Última mod.: 19 de out. de 2026 · CWE-837
0.3%EPSS · 30 dias0.3%
2026-10-202026-11-06
Thelia before 3.1.5 and 3.2.x before 3.2.4 contains a business logic vulnerability that allows authenticated customers to bypass coupon usage limits because usage is counted only when orders become paid. Attackers can place multiple pay-later orders while a usage remains, or cancel paid orders to inflate max_usage, gaining unlimited discounts.
- github.comhttps://github.com/thelia/thelia/blob/3.2.3/core/lib/Thelia/Action/Coupon.php
- github.comhttps://github.com/thelia/thelia/blob/3.2.3/core/lib/Thelia/Domain/Promotion/Coupon/Service/CouponManager.php
- github.comhttps://github.com/thelia/thelia/blob/3.2.3/core/lib/Thelia/Domain/Promotion/Coupon/Service/OrderCouponUsageManager.php
- github.comhttps://github.com/thelia/thelia/commit/1c3ed9c7ad57fec8ea959aa2d2f506f9892777ea
- github.comhttps://github.com/thelia/thelia/commit/edb7078bfce5ea31b40868d340b0b49dcc6cf00c
- github.comhttps://github.com/thelia/thelia/releases/tag/3.1.5
- github.comhttps://github.com/thelia/thelia/releases/tag/3.2.4
- github.comhttps://github.com/thelia/thelia/security/advisories/GHSA-pq5m-7g9w-ppg8
- www.vulncheck.comhttps://www.vulncheck.com/advisories/thelia-before-3.1.5-and-3.2.4-coupon-usage-limit-bypass-via-pay-later-orders
CVECVSSEPSSKEVRExploitTítuloMod.
CVE-2026-1058508.2 ALT23.8%
——7Payload is a free and open source headless content management system. In @payloadcms/plugin-ecommerce versions before 3.90.0 and canary versions before 4.0.0-canary.34, use of the Stripe payment adapter can allow a Stripe order confirmation to be processed more than once under certain conditions. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.24dCVE-2026-861984.2 MÉD32.4%
——10PocketMine-MP versions before 5.44.2 fail to properly validate multiple ResourcePackClientResponsePacket packets with STATUS_COMPLETED status during resource pack handling. Malicious clients can send batches of these packets to repeatedly trigger pre-spawn progression, creating duplicate Player objects and amplifying memory consumption and network traffic.58dCVE-2026-457345.3 MÉD46.3%
——14MyBB is free and open source forum software. Prior to 1.8.40, the built-in CAPTCHA does not consistently enforce single-use semantics, allowing remote attackers to bypass CAPTCHA controls through challenge replay. The successful validation paths in contact.php, member.php?action=do_resendactivation, member.php?action=do_lostpw, member.php?action=do_emailuser, and sendthread.php?action=do_sendtofriend do not call captcha::invalidate_captcha() for the MyBB Default CAPTCHA selected by the captchaimage setting. A valid response can therefore be reused until a non-vulnerable endpoint invalidates it, an incorrect response is submitted, or the challenge expires. This issue is fixed in version 1.8.40.60dCVE-2026-426098.1 ALT40.3%
——12Grav is a file-based Web platform. Prior to 2.0.0-beta.2, a business logic vulnerability in the Grav Admin Panel allows a low-privileged user (with only user creation permissions) to overwrite existing accounts, including the primary administrator. By creating a new user with a username that already exists, the system updates the existing account's metadata and permissions instead of rejecting the request. This leads to a Denial of Service (DoS) on administrative functions and Privilege De-escalation of the root account. This vulnerability is fixed in 2.0.0-beta.2.12dCVE-2026-446013.7 BAI27.2%
——8Tor before 0.4.9.7, when circuit queue memory pressure exists, can experience a client crash because of a double close of a circuit, aka TROVE-2026-009.12dCVE-2025-627845.3 MÉD13.0%
——4InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions before 1.6.5 contain a vulnerability where any plugin using a GUI with the GuiStorageElement and allows taking out items out of that element can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.5.30d