CVE-2026-42208
BerriAI LiteLLM SQL Injection Vulnerability
CVSS
9.8
Crítica
EPSS
89.4%
p100
KEV
SIM
8 de mai. de 2026
Exploit Today
80
0-100
Publicado: 8 de mai. de 2026 · Última mod.: 26 de out. de 2026 · CWE-89
Produto
BerriAI / LiteLLM
Vulnerabilidade
BerriAI LiteLLM SQL Injection Vulnerability
Adicionado ao KEV
8 de mai. de 2026
Corrigir até
11 de mai. de 2026
Uso conhecido em ransomware
Não
Descrição resumida
BerriAI LiteLLM contains a SQL injection vulnerability that allows an attacker to read data from the proxy's database and potentially modify it, leading to unauthorized access to the proxy and the credentials it manages.
Ação necessária
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Notas
https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc ; https://nvd.nist.gov/vuln/detail/CVE-2026-42208
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
- github.comhttps://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- github.comhttps://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc
- access.redhat.comhttps://access.redhat.com/security/cve/CVE-2026-42208
- bugzilla.redhat.comhttps://bugzilla.redhat.com/show_bug.cgi?id=2463965
- security.access.redhat.comhttps://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42208.json
- www.cisa.govhttps://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42208