PULSE
FEED
ransomqilin reclama a Insurance Audit Services · US · Financial Servicesransomn0n reclama a Company #137 · CAransomn0n reclama a Company #136 · DKransomn0n reclama a Company #135 · IDransomn0n reclama a Company #134 · USransomn0n reclama a Company #133 · USransomredact reclama a Omni Hotels & Resorts · US · Hospitalityransomakira reclama a Westboro Partnersransomakira reclama a System Plus · Technologyransomakira reclama a David L Wade & Associates · Professional Servicesransomakira reclama a Source Energy Services · CA · Energy & Utilitiesransomaoqin reclama a Sistel · BR · Technologyransombyod reclama a First and Final Warning - IHG Hotels & Resorts (Estate) · Hospitalityransomqilin reclama a Calvary Christian College · AU · Educationransomqilin reclama a Insurance Audit Services · US · Financial Servicesransomn0n reclama a Company #137 · CAransomn0n reclama a Company #136 · DKransomn0n reclama a Company #135 · IDransomn0n reclama a Company #134 · USransomn0n reclama a Company #133 · USransomredact reclama a Omni Hotels & Resorts · US · Hospitalityransomakira reclama a Westboro Partnersransomakira reclama a System Plus · Technologyransomakira reclama a David L Wade & Associates · Professional Servicesransomakira reclama a Source Energy Services · CA · Energy & Utilitiesransomaoqin reclama a Sistel · BR · Technologyransombyod reclama a First and Final Warning - IHG Hotels & Resorts (Estate) · Hospitalityransomqilin reclama a Calvary Christian College · AU · Education
← Todos os CVEs
CVE Watch2 de nov. de 2026

CVE-2026-97229

GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound Vulnerability

CVSS

10.0

Crítica

EPSS

65.2%

p99

KEV

SIM

29 de out. de 2026

Exploit Today

80

0-100

Publicado: 13 de out. de 2026 · Última mod.: 2 de nov. de 2026 · CWE-190

EPSS · 30d
0.5%EPSS · 30 dias65.2%
2026-10-132026-11-05
Ficha do catálogo KEV

Produto

GitLab / Community Edition and Enterprise Edition

Vulnerabilidade

GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound Vulnerability

Adicionado ao KEV

29 de out. de 2026

Corrigir até

1 de nov. de 2026

Uso conhecido em ransomware

Não

Descrição resumida

GitLab Community Edition and Enterprise Edition contain a integer overflow or wraparound vulnerability that could allow an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

Ação necessária

Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.

Notas

Other products can potentially be affected by the same underlying Ruby/Onigmo Integer Overflow issue in CI/CD Regular Expression Compiler. For more information please see: https://www.ruby-lang.org/en/news/2026/10/23/regexp-fixes-for-gitlab-cves ; https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/ ; BOD 26-04: https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk ; Forensics Triage Requirements: https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk ; https://nvd.nist.gov/vuln/detail/CVE-2026-97229

Descrição técnica

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

Referências oficiais
CVEs relacionados
CVECVSSEPSSKEVRExploitTítuloMod.
CVE-2026-1167877.5 ALT
—
——0FreeSWITCH is a Software Defined Telecom Stack enabling the digital transformation from proprietary telecom switches to a software implementation that runs on any commodity hardware. Prior to 1.11.2, mod_event_socket used an unauthenticated Content-Length value directly as the allocation size for an Event Socket message body. Negative or extremely large values could overflow the terminator calculation or force an allocation failure through a helper that aborts the FreeSWITCH process. The header is parsed before the Event Socket password, so any host admitted by apply-inbound-acl can trigger termination with its first packet; the default loopback ACL limits ordinary installations to local clients. The outbound socket dialplan path is also affected when FreeSWITCH connects to a hostile application server, and process termination drops every active call until the service is restarted. This issue is fixed in version 1.11.2.6h
CVE-2026-112109—
—
——0A local privilege escalation vulnerability in Thales SafeNet Authentication Client (SAC) SACSrv can allow an authenticated, non-administrator local user to trigger a heap-based buffer overflow through the service interface. Successful exploitation may allow arbitrary code execution with Local System privileges.This issue affects SAC releases up to and including 10.9 R3 GA (build 10.9.7449).8h
CVE-2026-1078918.1 ALT
—
——0musl libc before 1.2.7, when an untrusted regular expression is used with regcomp, has multiple integer overflows, possibly leading to incorrect allocation sizes and out-of-bounds heap writes.9h
CVE-2026-69005—
3.4%
——1Integer overflow in NPU driver parameter processing due to insufficient bounds checking.23h
CVE-2026-68984—
3.4%
——1In the Samsung Exynos NPU kernel driver, an integer overflow allows an unprivileged application to trigger memory corruption.23h
CVE-2026-181427.1 ALT
37.1%
——11IBM MQ 9.2.0.0 through 9.2.0.44 LTS, 9.3.0.0 through 9.3.0.42 LTS, 9.4.0.0 through 9.4.0.26 LTS, 9.4.0.0 through 9.4.5.1 CD, and 10.0.0.0 through 10.0.0.5 LTS and CD could allow a remote authenticated attacker to cause a denial of service and perform limited memory corruption due to an integer overflow.1d